summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authornico <nico@magicbroccoli.de>2020-10-26 21:09:25 +0100
committernico <nico@magicbroccoli.de>2020-10-26 21:09:25 +0100
commitdd7a17894c223577d58f5471c01ccdf53115b1a8 (patch)
tree776f9bf7e996260040636951d4626c50205fb4d4 /pyproject.toml
parentd9f876901cc4219c618a882449fc5a307edbdabd (diff)
code quality thingemagic stuff
+ add pre-commit framework + add black config file * black reformat
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..e834e5c
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,20 @@
+[tool.black]
+line-length = 120
+target-version = ['py37', 'py38']
+include = '\.pyi?$'
+exclude = '''
+(
+ /(
+ \.eggs # exclude a few common directories in the
+ | \.git # root of the project
+ | \.hg
+ | \.mypy_cache
+ | \.tox
+ | \.venv
+ | _build
+ | buck-out
+ | build
+ | dist
+ )/ # the root of the project
+)
+'''