aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authornico <nico@magicbroccoli.de>2019-12-22 04:05:41 +0100
committernico <nico@magicbroccoli.de>2019-12-22 04:05:41 +0100
commita604e18853c3be192e439889b30a372f18740230 (patch)
tree97bd66b5c215bc81e4f2e3bd0d475367cd9ab312 /setup.py
parent43a03eaf920c1371d033feaf6679771b6c3016a5 (diff)
setup is difficult
* inversed checkdate to simplify * finished setup.py + add MANIFEST file
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 20 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 3fbb8aa..2bccdd9 100644
--- a/setup.py
+++ b/setup.py
@@ -3,6 +3,7 @@ from setuptools import setup, find_packages
from TSGroupAssigner import __version__
+# long readme
with open("README.md", "r") as fh:
long_description = fh.read()
@@ -13,19 +14,30 @@ setup(
author='nico wellpott',
author_email='nico@magicbroccoli.de',
classifiers=[
- 'Programming Language :: Python :: 3',
'Intended Audience :: System Administrators',
- 'Operating System :: Unix',
+ 'Natural Language :: English',
'License :: OSI Approved :: GNU General Public License v3 (GPLv3)',
- "Topic :: Communications",
- "Topic :: Internet"
- ],
+ 'Operating System :: Unix',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Topic :: Communications',
+ 'Topic :: Internet'
+ ],
license='GPLv3',
description='date based TeamSpeak Group Assigner',
long_description=long_description,
long_description_content_type='text/markdown',
keywords='automation TeamSpeak teamspeak ts3 ts3server ts',
- install_requires='ts3>=1.0.11',
- packages=find_packages(exclude=("tests",)),
- python_requires='>=3.6'
+ install_requires=[
+ 'ts3>=1.0.11,<2'
+ ],
+ packages=find_packages(exclude=('tests',)),
+ python_requires='>=3.6',
+ project_urls={
+ 'Source': 'https://github.com/mightyBroccoli/TSGroupAssigner',
+ 'Issue-Tracker': 'https://github.com/mightyBroccoli/TSGroupAssigner/issues'
+ }
)