aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authornico <nico@magicbroccoli.de>2019-12-11 17:31:21 +0100
committernico <nico@magicbroccoli.de>2019-12-11 17:31:21 +0100
commit825353e79e51b841d4783b6e187afa083a729e24 (patch)
treea7d199355ae9360c0828957329358bbb6283ff5f /setup.py
parent9080c719dc0252b43fd894d71cf7d410ae8b0cb6 (diff)
TSGroupAssigner setup
+ working release TSGroupAssigner module + add GPL Licence + add basic README * updated .gitignore - remove old script snippets
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..f296015
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,26 @@
+# -*- coding: utf-8 -*-
+from setuptools import setup, find_packages
+
+with open("README.md", "r") as fh:
+ long_description = fh.read()
+
+
+setup(
+ name='TSGroupAssigner',
+ version='0.0.1',
+ packages=find_packages(exclude=['tests', 'tests.*']),
+ keywords='automation TeamSpeak teamspeak ts3 ts3server ts',
+ url='https://github.com/mightyBroccoli/TSGroupAssigner',
+ license='GPLv3',
+ author='nico wellpott',
+ author_email='nico@magicbroccoli.de',
+ description='date based TeamSpeak Group Assigner',
+ long_description=long_description,
+ python_requires='>=3.7',
+ classifiers=[
+ 'Programming Language :: Python :: 3',
+ 'Intended Audience :: System Administrators',
+ 'Operating System :: Unix',
+ 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)'
+ ]
+)