aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authornico <nico@magicbroccoli.de>2020-06-27 12:07:09 +0200
committernico <nico@magicbroccoli.de>2020-06-27 12:07:09 +0200
commit8b26b1eb8e5cd8d69e600a4c4eec9bea28ef8059 (patch)
tree0cbf83fb8f5245a9178e98e4a851f38d8261a8f8 /pyproject.toml
parentfa87c166ed68fac05970ae60eda532d6ba5a851a (diff)
tool configuration
* seperate tool config and tool call * rename black stage to code consistency for a greater readability - remove allow_failure from the third stage I did decide to remove the allowed failure tag to encourage a higher code quality.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..e834e5c
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,20 @@
+[tool.black]
+line-length = 120
+target-version = ['py37', 'py38']
+include = '\.pyi?$'
+exclude = '''
+(
+ /(
+ \.eggs # exclude a few common directories in the
+ | \.git # root of the project
+ | \.hg
+ | \.mypy_cache
+ | \.tox
+ | \.venv
+ | _build
+ | buck-out
+ | build
+ | dist
+ )/ # the root of the project
+)
+'''