diff options
author | nico <nico@magicbroccoli.de> | 2019-12-19 18:15:47 +0100 |
---|---|---|
committer | nico <nico@magicbroccoli.de> | 2019-12-19 18:15:47 +0100 |
commit | 9b964690e79b5a4366e43fde01c6594de693be4d (patch) | |
tree | 72dd4c1ee364a44d6aedde66a798af239b3be44a /setup.py | |
parent | 6f19f160ef0d2d72c1db35abcf03ee28a3982d7c (diff) |
package finish up
* update setup.py
* better format the main __init__ file
* move exceptions to separate file for maintainability
* small corrections
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 24 |
1 files changed, 15 insertions, 9 deletions
@@ -1,25 +1,31 @@ # -*- coding: utf-8 -*- from setuptools import setup, find_packages +from TSGroupAssigner import __version__ + with open("README.md", "r") as fh: long_description = fh.read() setup( name='TSGroupAssigner', - version='0.0.1', - packages=find_packages(exclude=['tests', 'tests.*']), - keywords='automation TeamSpeak teamspeak ts3 ts3server ts', + version=__version__, url='https://github.com/mightyBroccoli/TSGroupAssigner', - license='GPLv3', author='nico wellpott', author_email='nico@magicbroccoli.de', - description='date based TeamSpeak Group Assigner', - long_description=long_description, - python_requires='>=3.7', classifiers=[ 'Programming Language :: Python :: 3', 'Intended Audience :: System Administrators', 'Operating System :: Unix', - 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)' - ] + 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)', + "Topic :: Communications", + "Topic :: Internet" + ], + license='GPLv3', + description='date based TeamSpeak Group Assigner', + long_description=long_description, + long_description_content_type='text/markdown', + keywords='automation TeamSpeak teamspeak ts3 ts3server ts', + install_requires='ts3>=1.0.11', + packages=find_packages(exclude=("tests",)), + python_requires='>=3.6' ) |