aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorgenofire <geno+dev@fireorbit.de>2020-06-29 19:34:48 +0200
committergenofire <geno+dev@fireorbit.de>2020-06-29 19:34:48 +0200
commit091b6e525aacad1abf8d800338d242141dec11c2 (patch)
tree73137b27409b00a45c76c2bfbf4b5e9d029a4ff1 /pyproject.toml
parent1256ea7de8a093f51b116f2802871480cd646ae8 (diff)
parent044e0334d2bfb9c4b076afc562e4fb3d17c7db20 (diff)
Merge branch 'add-ci' into 'master'
Add ci See merge request sum7/ejabberd-tools!6
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml20
1 files changed, 20 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..e834e5c
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,20 @@
+[tool.black]
+line-length = 120
+target-version = ['py37', 'py38']
+include = '\.pyi?$'
+exclude = '''
+(
+ /(
+ \.eggs # exclude a few common directories in the
+ | \.git # root of the project
+ | \.hg
+ | \.mypy_cache
+ | \.tox
+ | \.venv
+ | _build
+ | buck-out
+ | build
+ | dist
+ )/ # the root of the project
+)
+'''